Как программно открыть, передать параметры и сформировать бухгалтерский отчет по текущей строке таблицы товаров?

Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как программно открыть, передать параметры и сформировать бухгалтерский отчет по текущей строке таблицы товаров?, Процедура, открывающая отчет, передает параметры, настройки и отбор в бухгалтерский отчет. Отчет формируется по текущей строке табличного документа (передается в параметры процедуры)
 
Вот так:

Код
// Открывает карточку счета для выделенного товара в табличной части
Процедура ОткрытьКарточкуСчета(ТабЧасть)
   // Создаем отчет
   ОтчетКарточкаСчета = Отчеты.КарточкаСчетаХозрасчетный.Создать();
   
   // Создаем таблицу отбора
   ТаблицаОтбора = Новый ТаблицаЗначений;
    ТаблицаОтбора.Колонки.Добавить("Имя");
    ТаблицаОтбора.Колонки.Добавить("ПутьКДанным");
    ТаблицаОтбора.Колонки.Добавить("ВидСравнения");
    ТаблицаОтбора.Колонки.Добавить("Использование");
    ТаблицаОтбора.Колонки.Добавить("Значение");
    ТаблицаОтбора.Колонки.Добавить("ЗначениеС");
    ТаблицаОтбора.Колонки.Добавить("ЗначениеПо");
   
   // Добавляем значение отбора
    НоваяСтрока  = ТаблицаОтбора.Добавить();
    НоваяСтрока.Имя = "Номенклатура";
    НоваяСтрока.ПутьКДанным = "Субконто1";
    НоваяСтрока.ВидСравнения = ВидСравнения.Равно;
   НоваяСтрока.Использование = Истина;
   Если ТабЧасть.ТекущаяСтрока <> Неопределено Тогда
       НоваяСтрока.Значение = ТабЧасть.ТекущаяСтрока.Номенклатура;
   КонецЕсли;
    НоваяСтрока.ЗначениеС = Null;
    НоваяСтрока.ЗначениеПо = Null;

   // Создаем структуру параметров   
   СтруктураПараметров=Новый Структура;
   СтруктураПараметров.Вставить("Счет",ПланыСчетов.Хозрасчетный.ТоварыНаСкладе);
   СтруктураПараметров.Вставить("Организация",Организация);
   СтруктураПараметров.Вставить("ДатаНач",Дата);
    СтруктураПараметров.Вставить("ДатаКон",РабочаяДата);
    СтруктураПараметров.Вставить("Отбор",ТаблицаОтбора);
   
   // Открываем форму
   ФормаОтчета = ОтчетКарточкаСчета.ПолучитьФорму();
   ФормаОтчета.Открыть();
   
   // Настраиваем отчет
   ОтчетКарточкаСчета.Настроить(СтруктураПараметров);
   
   // Формируем отчет
   Если ТабЧасть.ТекущаяСтрока <> Неопределено Тогда
      ФормаОтчета.ОбновитьОтчет();
   КонецЕсли;
КонецПроцедуры
Все нужно проектировать сверху вниз, за исключением фундамента, с
которого нужно начинать.
Страницы: 1
Читают тему